problems with filter

Post any questions you have about a turtle indoor setup here. Or if you have a link to your indoor setup picture we would love to see it.
Locked
MishFish
Level 3
Level 3
Posts: 159
Joined: Sat Sep 07, 2002 8:47 pm
Contact:

Hey,
We finally have everything set up and ready to go in our new tank. The only problem is our filter. It\'s an \'aqua tec 30-60\' that hangs on the side of the tank. It came with an extension tube for lower tanks so in theory this filter should work(and the pet shop ppl told us this would work)...but, everything is set up right in the filter and it won\'t pump. I\'ve been trying to prime it but it usually loses all the water. When I put the tubing on the highest level, the water will stay in the filter but won\'t pump anymore in??...Does anyone know what I\'m talking about or can help??
We\'ve been trying this constantly for two days and nothing is work.
GlennThiltgen
Level 3
Level 3
Posts: 190
Joined: Thu Aug 15, 2002 12:22 am
Contact:

You may have to raise the water level far above the piece that hangs in the water. I hated using filters that hang on the side because you have to have your water over that piece in order for it to work. So i just purchased a submersible filter. Those seem to work better and you can have your water level at almost any level you prefer.
MishFish
Level 3
Level 3
Posts: 159
Joined: Sat Sep 07, 2002 8:47 pm
Contact:

I really wanted to buy a submersible filter but we got a deal on a tank with all this stuff in it so I just ended up buying that. We finally got a call back from the help line and they told us about the water level which is really odd why they would have an extension tube for low tanks??....and that the water level would have to be high... we\'re going to attemp to glue a sort of container around the tube that will hold some water to fool the filter...
i\'ll let ya know what happens
sarky
Level 2
Level 2
Posts: 35
Joined: Tue Sep 03, 2002 11:44 pm
Contact:

I have been having the same problem with my filter, it is very annoying. I have to keep an eye on the water level because even when I fill it up to far above the extension piece, after a day or two the water evaporates.

Can you recommend a good submersible filter?
mafianick
Level 1
Level 1
Posts: 8
Joined: Tue Oct 22, 2002 10:07 pm
Contact:

I had the same problem, i tried to prime it, it just dident have enough power to suck the water up over the side. I got a fluval filter that i just stick underwater now, it works much better
Fofusu
Level 1
Level 1
Posts: 8
Joined: Wed Oct 30, 2002 11:22 pm
Contact:

(Hello, just joined, my first post)

So this is a problem with all hanging filters? I just bought a Penguin Mini filter and its got a long enough tube which reaches close to the bottom of my aquarium. The bottom of the tube is completely immersed in water so I was thinking this should be fine.

But the problem is the same as above, the penguin mini is not pumping water at all.

There is nothing to be done about this?
Locked
  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest