HELP!!! please! Turtle tank problems

Post your turtle first aid questions here.
Post Reply
Guest

I am having THE hardest time keeping my RES\'s tank clean. He\'s only about 4 inches long, but the water is terrible! We have a pretty decent filter, only the biological sponge part is always geting clogged, but we can\'t wash it or the bacteria will die... The water would get SO cloudy and bad smelling in a couple of days, so we took all of the little pebbles on the bottom out and boiled them in case there was an algae bloom or something, and disinfected everything else...but it didn\'t do any good. We finally decided the pebbles were too hard to keep clean, so we replaced them with a few bigger rocks, and I got some liquid stuff that complements the biological part of the filter by making the waste and leftover food easier to break down, fully cleaned out the filter, rocks, and tank yesterday and put the liquid stuff in, and this morning it was cloudy again! arrrgh... I have no idea what to do... The only thing I can think of is that the current from the filter makes the pellets dissolve faster and it\'s too much for the filter to handle...but even then it shouldn\'t have gotten that bad so fast... help?!
deesygirl
Moderator
Moderator
Posts: 220
Joined: Thu Sep 12, 2002 4:37 pm
Contact:

It is a filter problem. First of all that gunk you put in the water, I tried the same stuff, had the same problem. You really need a good canister filter. The effect that you are getting is the same as having no filter at all. Also a tank does need a certain amount of bacteria to balance its self. I swish the rocks around in the water when I do a water change but I never \"clean\" them off all the way. Also some people here use a seperate tank to feed in. I use the same tank but turn my filter off for a few minutes.
Good luck
herpgirl85
Level 1
Level 1
Posts: 21
Joined: Thu Jan 17, 2002 10:09 pm
Contact:

It\'s only a 10 gallon, and it\'s about half full. maybe a little more. Actually, someone just mentioned in another post that they are finding pink goo in their filter, I\'ve got the same problem, only mine is kind of a pinkish-red rusty colour. I figured it was algae of some kind.
Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 0 guests